* IBM_PROLOG_BEGIN_TAG * This is an automatically generated prolog. * * perf720 src/perf/perfagent/usr/lpp/perfagent/README.perfagent.tools 1.7.1.8 * * * * OBJECT CODE ONLY SOURCE MATERIALS * * COPYRIGHT International Business Machines Corp. 1993,2007 * All Rights Reserved * * The source code for this program is not published or otherwise * divested of its trade secrets, irrespective of what has been * deposited with the U.S. Copyright Office. * * IBM_PROLOG_END_TAG * * COMPONENT_NAME: (CMDPERFT) AIX Performance Analysis Tools * * FUNCTIONS: README * * ORIGINS: 30 * * (C) COPYRIGHT International Business Machines Corp. 2002 * * All Rights Reserved. * Licensed Materials - Property of IBM * * US Government Users Restricted Rights - Use, duplication or * disclosure restricted by GSA ADP Schedule Contract with IBM Corp. * ======================================================================== The information contained in this file consists of a description of a set of performance tools which may be used to evaluate and tune AIX system performance. For more detailed information on each of the tools, type "man 'toolname'". In AIX Version 5, most of the performance tools were moved to the bos.perf.tools fileset. ======================================================================== DESCRIPTION OF CONTENTS Topas Cross-Partition View and Recording (-C | -R) This panel displays metrics similar to the lparstat command for all the AIX partitions it can identify as belonging to the same hardware platform. Dedicated and shared partitions are displayed in separate sections with appropriate metrics. The top section represents aggregated data from the partition set to show overall partition, memory, and processor activity. Remote enablement for this panel to collect from other partitions requires that latest updates to the perfagent.tools and bos.perf.tools used to support this function. For earlier versions of AIX, the topas command also collects remote data from partitions that have the Performance Aide product (perfagent.server) installed. topas -C may not be able to locate partitions residing on other subnets. To circumvent this, create a $HOME/Rsi.hosts file containing the fully qualified hostnames for each partition (including domains), one host per line. Besides the display option, the topas -R option will run topas in the background (with no display) and record the Cross-Partition data. Recordings are made to the /etc/perf/ directory, and are of the form topas_cec.YYMMDD. Recordings cover single-day periods (24 hours) and are retained for 8 days before being automatically deleted. This allows a weeks worth of data to be retained on the system at all times. The topasout command is used to covert these recordings into various text-based reports. Customers using the topas -R function on an LPAR-capable system should identify a single partition for collecting and recording this data. The /usr/lpp/perfagent/config_topas.sh script can be used to automatically update the system /etc/inittab file to execute topas -R on startup. The following metrics display in the initial Cross-Partition panel. Additional metrics with full descriptive labels can be displayed by using the key toggles identified in the Additional Cross-Partition Panel Subcommands section in the AIX commands manual pages: Partition totals Shr Number of shared partitions Ded Number of dedicated partitions Memory (in GB) Mon Monitored partitions total memory Avl Memory available to partition set InUse Memory in use on monitored partitions Processor Shr Number of shared processors Ded Number of dedicated processors PSz Active physical CPUs in the shared processor pool being used by this LPAR APP Available physical processors in the shared pool Shr_PhysB Shared Physical Busy Ded_PhysB Dedicated Physical Busy Individual partition data Host Hostname OS Operating system level M Mode For shared partitions C - SMT enabled & capped c - SMT disabled & capped U - SMT enabled & uncapped u - SMT disabled & uncapped For dedicated partitions S - SMT enabled ' ' (blank) - SMT disabled Mem Total memory in GB. InU Memory in use in GB. Lp Number of logical processors Us Percentage of CPU used by programs executing in user mode. Sy Percentage of CPU used by programs executing in kernel mode. Wa Percentage of time spent waiting for IO. Id Percentage of time the CPU(s) is idle. PhysB Physical Processors Busy Ent Entitlement granted (shared-only) %Entc Percent Entitlement consumed (shared-only) Vcsw Virtual context switches average per second (shared-only) PhI Phantom interrupts average per second (shared-only) Note: At least one partition to be monitored must have Pool Utilization Authority (PUA) configured for pool information metrics to be collected. For cross-partition monitoring/recording, some global data is not available from any partition. The -o options allow users to specify those fields in the command line. Optionally, users can configure a system to allow topas to query the HMC directly for this information. This requires the following steps: 1. Install OpenSSH at the partition. 2. Enable remote command support on the HMC for user hscroot to allow ssh connections to be opened from the partition. 3. Configure ssh on the HMC to not require a password for the HMC user hscroot when queried from the selected partition. This requires the .ssh/authorized_keys2 on the HMC for user login hscroot. 4. Try "ssh -l hscroot date" from the partition to check whether the date is displayed without entering password. 5. Utilize the topas -o options described in the usage table to specify the managed system and HMC names when executing topas. Note: This functionality is currently available only for HMC version 5 and above, and should only be enabled after careful consideration of any security implications. For customers who have configured the topas hosting partition to query the noHMC (see above), these options are used to specify the managed system and HMC hostname: -o managedsys = [managed system name under which this partition is configured] -o hmc = [HMC name under which this partition is configured available via: lsrsrc -dx IBM.ManagementServer Hostname] The HMC name as a parameter is optional and can be used when the resource class IBM.ManagementServer is not configured in RMC. It is preferred that the IP address of the HMC be provided instead of the host name. The managed system name needs to be specified as a parameter for topas for the query. If the HMC platform cannot be configured for automatic queries, then the global data fields not available to the local partition may be set via these options: -o availmem = [total amount of memory allocated to all partitions, in GB] -o unavailmem = [total amount of memory unallocated from the HMC, in GB] -o availcpu = [total number of physical processors allocated for all partitions] -o unavailcpu = [total number of physical processors unallocated from the HMC] -o poolsize = [defined Pool Size required if HMC Processor Utilization Authority restricts access] -o partitions = [number of partitions defined on the HMC] -o reconfig = [number of seconds between checking for HMC configuration changes. Allowed values are 30, 60, 90, 120, 180, 240, 300 seconds. The default is 300 seconds] Topasout formatted reports Post-process topas CEC or xmwlm local recordings to generate a text report. The -s option should be used if a standard spreadsheet type is desired, no -R argument is required. Additional options are: For local recordings generated by xmwlm -L: type = detailed [prints a formatted output report similar to the topas main display] type = summary [prints a single-line formatted output report of the system] type = disk [prints the report containing the disk metrics of the system] type = lan [prints the report containning the metrics related to network interfaces of the system] For recordings generated by topas -R: type = detailed [prints a formatted output report similar to the topas CEC monitoring display] type = summary [prints the CEC processor and memory summary report] -i MM [split the recording reports into equal size time periods. This must be a multiple of the recording interval, which by default is 5 minutes. Allowed values are 5, 10, 15, 30, 60] -b HHMM [begin time in hours (HH) and minutes (MM). This must be a range between 0000 and 2400] -e HHMM [end time in hours (HH) and minutes (MM). This must be a time greater than the begin time] If -b and -e options are not used, the given recording file will be processed from beginning to end. eg: topasout -R detailed /etc/perf/daily/xmwlm.060907 will generate a detailed report of the system. topasout -R disk /etc/perf/daily/xmwlm.060907 will generate a report containing disk metrics. ================================================================================ topasout Command for nmon analyzer Purpose topasout is used to post process the binary recording file generated by xmwlm. This command also generates the csv file this is used by nmon analyzer to produce some nice graphs to aid in analysis and report writing. It requires Excel 2002 or later. Syntax topasout -a recording_file Flags: -a Specifies that topasout should format the output files as comma separated file for analysis and longer term data capture. Use this together with nmon Analyzer Excel 2002 spreadsheet, which loads the nmon output file and automatically creates dozens of graphs ready for you to study or write performance reports. Note : Currently this feature do not support CPU DR operation. Examples: 1. The following is an example of topasout comman-seperated for nmon analyzer format: CPU_ALL,CPU Total ,User%,Sys%,Wait%,Idle%,CPUs, CPU01,CPU Total ,User%,Sys%,Wait%,Idle%, CPU00,CPU Total ,User%,Sys%,Wait%,Idle%, DISKBUSY,Disk %Busy ,hdisk1,hdisk0, DISKREAD,Disk Read kb/s ,hdisk1,hdisk0, DISKWRITE,Disk Write kb/s ,hdisk1,hdisk0, DISKXFER,Disk transfers per second ,hdisk1,hdisk0, DISKSERV,Disk Avg service time/transfer ,hdisk1,hdisk0, DISKWAIT,Average wait queue time for read/write transfers,hdisk1,hdisk0, MEMREAL,Real Memory Statistics,Size 4k pages,free frames 4k,%pinned,%comp,%noncomp,%client, MEMVIRT,PgSp / Virtual Memory Statistics,PageSpace,%free,%used,pagein,pageout,pgspgin,pgspgout,sio,t otfaults,steal, PROC,Processes ,Runnable,Swap-in,pswitch,syscall,read,write,fork,exec,loadavg,utilavg,numprocs, LAN,LAN Interfaces Statistics,ent0/kbytesout,ent0/kbytesin,ent0/framesout,ent0/framesin,ent0/recvdro ps, IP,IP Statistics for network interface,lo0/ipacket,en0/ipacket,lo0/opacket,en0/opacket,lo0/ioctet_kb ,en0/ioctet_kb,lo0/ooctet_kb,en0/ooctet_kb, TCPUDP,IP Protocol statistics,TCPSendTot,TCPRcvTot,UDPSnddgrm,UDPRcvdgrm, FILE,File I/O ,iget,namei,dirblk,readch,writech, JFSFILE,JFS Filespace %Used,/,/home,/usr,/var,/tmp,/opt, JFSINODE,JFS Inode %Used,/,/home,/usr,/var,/tmp,opt, LPAR,LPAR Stats,PhysicalCPU,VirtualCPUs,LogicalCPUs,poolCPUS,entitled,weight,poolIdle,UsedAllCPU%,Us edPoolCPU%,SharedCPU, ZZZZ,T0001,06:18:02,25-04-2006,, ................................... 2. topasout -a xmwlm.060501 to generate the csv file xmwlm.060501.csv Please find more details of the nmonanalyser tool developed by Stephen Atkins in the link given below: http://www-941.haw.ibm.com/collaboration/wiki/display/Wikiptype/nmonanalyser Please contact IBM PTX Support for any issues while using topasout with nmonanalyser. =============================================================================== Commands not supported inside a WPAR ------------------------------------- All commands that use SPMI are not supported inside a WPAR. In perfagent.tools fileset, xmwlm and xmtopas are not supported inside a WPAR